Mozilla попробует принудительно обновить старые браузеры Firefox

До сих пор многие пользователи Firefox ведут себя совершенно безответственно, отказываясь обновляться на новые версии, в которых исправлены многочисленные уязвимости. Проблема особенно актуальна для тех, у кого установлены особенно старые версии, где отсутствует модуль автоматического обновления. Проведённое организацией Mozilla исследование показало, что от 50% до 70% таких пользователей просто не знают о возможности обновления и о том, что используют небезопасную версию программы.

Среди остальных есть и более грамотные, которые специально сохраняют старую версию браузера в силу разных причин. Например, чтобы не испортить работу расширений, которые перестали поддерживаться в новых версиях.

По статистике, примерно 2% пользователей каждой версии Firefox «застревают» на ней и прекращают обновления. Особенно высок процент пользователей, «застрявших» на Firefox 3.6.x и Firefox 12.

Mozilla попытается решить эту проблему несколькими способами. Во-первых, для пользователей Firefox 3.6 и более ранних версий будет изменён сервер обновлений, чтобы апдейты преподносились как незначительные, а не как важные. Это позволит обойти проверку совместимости расширений, так что обновление произойдёт даже в том случае, если расширения не совместимы с ним.

Во-вторых, готовится специальное исправление типа addon hotfix для Firefox 11 и старше, потому что Firefox 11 является первой версией, в которой поддерживаются подобного типа исправления. Обновление затронет все версии Firefox 11-26, за исключением Firefox 24 ESR.

Исправление стимулирует обновление на более новую версию браузера. Пока что обсуждается, как именно его применить и когда. Вероятно, это случится вскоре после выпуска Firefox 30, для начала только для пользователей Windows. Если операция пройдёт успешно, то её повторят для пользователей Mac.

Mozilla подчёркивает, что уважает право пользователя на самоопределение, так что не будет показывать новое окно с просьбой обновиться или принудительно устанавливать новую версию у тех, кто явно запретил обновление в настройках браузера.

http://xakep.ru/news/62493/

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *